CVE-2022-36005 is a medium-severity (CVSS 5.9) Reachable Assertion vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.
`CHECK` fail in `FakeQuantWithMinMaxVarsGradient` in TensorFlow
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When tf.quantization.fake_quant_with_min_max_vars_gradient receives input min or max that is nonscalar, it gives a CHECK fail that can trigger a denial of service attack.
import tensorflow as tf
import numpy as np
arg_0=tf.constant(value=np.random.random(size=(2, 2)), shape=(2, 2), dtype=tf.float32)
arg_1=tf.constant(value=np.random.random(size=(2, 2)), shape=(2, 2), dtype=tf.float32)
arg_2=tf.constant(value=np.random.random(size=(2, 2)), shape=(2, 2), dtype=tf.float32)
arg_3=tf.constant(value=np.random.random(size=(2, 2)), shape=(2, 2), dtype=tf.float32)
arg_4=8
arg_5=False
arg_6=''
tf.quantization.fake_quant_with_min_max_vars_gradient(gradients=arg_0, inputs=arg_1,
min=arg_2, max=arg_3, num_bits=arg_4, narrow_range=arg_5, name=arg_6)
Patches
We have patched the issue in GitHub commit f3cf67ac5705f4f04721d15e485e192bb319feed.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by
- 刘力源, Information System & Security and Countermeasures Experiments Center, Beijing Institute of Technology
- Neophytos Christou, Secure Systems Labs, Brown University
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.7.2pip install --upgrade 'tensorflow==2.7.2' |
| 🐍PyPI | tensorflow | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow==2.8.1' |
| 🐍PyPI | tensorflow | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow==2.9.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.7.2pip install --upgrade 'tensorflow-cpu==2.7.2' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow-cpu==2.8.1' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow-cpu==2.9.1' |
Affected Products
tensorflowgoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-36005 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2022-36005 in your dependencies?
Find it across PyPI, including transitive dependencies.