NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-35993 — tensorflow

MEDIUMFix: tensorflow/tensorflow@cf70b79

CVE-2022-35993 is a medium-severity (CVSS 5.9) Reachable Assertion vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.

`CHECK` fail in `SetSize` in TensorFlow

Also known asBIT-tensorflow-2022-35993GHSA-wq6q-6m32-9rv9PYSEC-2026-1044PYSEC-2026-3255PYSEC-2026-3378
Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.33%0.65%0.98%0.1%0.5%Jun 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐍tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

When SetSize receives an input set_shape that is not a 1D tensor, it gives a CHECK fails that can be used to trigger a denial of service attack.

import tensorflow as tf
arg_0=1
arg_1=[1,1]
arg_2=1
arg_3=True
arg_4=''
tf.raw_ops.SetSize(set_indices=arg_0, set_values=arg_1, set_shape=arg_2,
                   validate_indices=arg_3, name=arg_4)

Patches

We have patched the issue in GitHub commit cf70b79d2662c0d3c6af74583641e345fc939467.

The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by 刘力源, Information System & Security and Countermeasures Experiments Center, Beijing Institute of Technology.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItensorflowall versions2.7.2pip install --upgrade 'tensorflow==2.7.2'
🐍PyPItensorflow≥ 2.8.0&&< 2.8.12.8.1pip install --upgrade 'tensorflow==2.8.1'
🐍PyPItensorflow≥ 2.9.0&&< 2.9.12.9.1pip install --upgrade 'tensorflow==2.9.1'
🐍PyPItensorflow-cpuall versions2.7.2pip install --upgrade 'tensorflow-cpu==2.7.2'
🐍PyPItensorflow-cpu≥ 2.8.0&&< 2.8.12.8.1pip install --upgrade 'tensorflow-cpu==2.8.1'
🐍PyPItensorflow-cpu≥ 2.9.0&&< 2.9.12.9.1pip install --upgrade 'tensorflow-cpu==2.9.1'

Affected Products

1 product · 7 configurations
Application
tensorflowgoogle
≥ 2.9.0 && < 2.9.1
1 version
2.10

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tensorflow to 2.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35993 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact When `SetSize` receives an input `set_shape` that is not a 1D tensor, it gives a `CHECK` fails that can be used to trigger a denial of service attack. ```python import tensorflow as tf arg_0=1 arg_1=[1,1] arg_2=1 arg_3=True arg_4='' tf.raw_ops.SetSize(set_indices=arg_0, set_values=arg_1, set_shape=arg_2, validate_indices=arg_3, name=arg_4) ``` ### Patches We have patched the issue in GitHub commit [cf70b79d2662c0d3c6af74583641e345fc939467](https://github.com/tensorflow/tensorflow/commit/cf70b79d2662c0d3c6af74583641e345fc939467). The fix will be included in Tenso
O3 Security · Impact-Aware SCA

Is CVE-2022-35993 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-35993: tensorflow DoS — Fixed in 2.7.2