NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-35965 — tensorflow

MEDIUMFix: tensorflow/tensorflow@bce3717

CVE-2022-35965 is a medium-severity (CVSS 5.9) NULL Pointer Dereference vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.

Segfault in `LowerBound` and `UpperBound` in TensorFlow

Also known asBIT-tensorflow-2022-35965GHSA-qxpx-j395-pw36PYSEC-2026-1030PYSEC-2026-3233PYSEC-2026-3363
Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-35965.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.32%0.64%0.96%0.1%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐍tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

If LowerBound or UpperBound is given an emptysorted_inputs input, it results in a nullptr dereference, leading to a segfault that can be used to trigger a denial of service attack.

import tensorflow as tf

out_type = tf.int32
sorted_inputs = tf.constant([], shape=[10,0], dtype=tf.float32)
values = tf.constant([], shape=[10,10,0,10,0], dtype=tf.float32)
tf.raw_ops.LowerBound(sorted_inputs=sorted_inputs, values=values, out_type=out_type)
import tensorflow as tf

out_type = tf.int64
sorted_inputs = tf.constant([], shape=[2,2,0,0,0,0,0,2], dtype=tf.float32)
values = tf.constant(0.372660398, shape=[2,4], dtype=tf.float32)
tf.raw_ops.UpperBound(sorted_inputs=sorted_inputs, values=values, out_type=out_type)

Patches

We have patched the issue in GitHub commit bce3717eaef4f769019fd18e990464ca4a2efeea.

The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported by Neophytos Christou, Secure Systems Labs, Brown University.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItensorflowall versions2.7.2pip install --upgrade 'tensorflow==2.7.2'
🐍PyPItensorflow≥ 2.8.0&&< 2.8.12.8.1pip install --upgrade 'tensorflow==2.8.1'
🐍PyPItensorflow≥ 2.9.0&&< 2.9.12.9.1pip install --upgrade 'tensorflow==2.9.1'
🐍PyPItensorflow-cpuall versions2.7.2pip install --upgrade 'tensorflow-cpu==2.7.2'
🐍PyPItensorflow-cpu≥ 2.8.0&&< 2.8.12.8.1pip install --upgrade 'tensorflow-cpu==2.8.1'
🐍PyPItensorflow-cpu≥ 2.9.0&&< 2.9.12.9.1pip install --upgrade 'tensorflow-cpu==2.9.1'

Affected Products

1 product · 7 configurations
Application
tensorflowgoogle
≥ 2.9.0 && < 2.9.1
1 version
2.10

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tensorflow to 2.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35965 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact If `LowerBound` or `UpperBound` is given an empty`sorted_inputs` input, it results in a `nullptr` dereference, leading to a segfault that can be used to trigger a denial of service attack. ```python import tensorflow as tf out_type = tf.int32 sorted_inputs = tf.constant([], shape=[10,0], dtype=tf.float32) values = tf.constant([], shape=[10,10,0,10,0], dtype=tf.float32) tf.raw_ops.LowerBound(sorted_inputs=sorted_inputs, values=values, out_type=out_type) ``` ```python import tensorflow as tf out_type = tf.int64 sorted_inputs = tf.constant([], shape=[2,2,0,0,0,0,0,2], dtype=tf.float3
O3 Security · Impact-Aware SCA

Is CVE-2022-35965 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-35965: tensorflow DoS — Fixed in 2.7.2