CVE-2022-35963 is a medium-severity (CVSS 5.9) Reachable Assertion vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.
`CHECK` failures in `FractionalAvgPoolGrad` in TensorFlow
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-35963.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The implementation of FractionalAvgPoolGrad does not fully validate the input orig_input_tensor_shape. This results in an overflow that results in a CHECK failure which can be used to trigger a denial of service attack.
import tensorflow as tf
overlapping = True
orig_input_tensor_shape = tf.constant(-1879048192, shape=[4], dtype=tf.int64)
out_backprop = tf.constant([], shape=[0,0,0,0], dtype=tf.float64)
row_pooling_sequence = tf.constant(1, shape=[4], dtype=tf.int64)
col_pooling_sequence = tf.constant(1, shape=[4], dtype=tf.int64)
tf.raw_ops.FractionalAvgPoolGrad(orig_input_tensor_shape=orig_input_tensor_shape, out_backprop=out_backprop, row_pooling_sequence=row_pooling_sequence, col_pooling_sequence=col_pooling_sequence, overlapping=overlapping)
Patches
We have patched the issue in GitHub commit 03a659d7be9a1154fdf5eeac221e5950fec07dad.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Neophytos Christou, Secure Systems Labs, Brown University.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.7.2pip install --upgrade 'tensorflow==2.7.2' |
| 🐍PyPI | tensorflow | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow==2.8.1' |
| 🐍PyPI | tensorflow | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow==2.9.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.7.2pip install --upgrade 'tensorflow-cpu==2.7.2' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow-cpu==2.8.1' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow-cpu==2.9.1' |
Affected Products
tensorflowgoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35963 is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is CVE-2022-35963 in your dependencies?
Find it across PyPI, including transitive dependencies.