CVE-2022-35940 is a medium-severity (CVSS 5.9) CWE-190 vulnerability in tensorflow. A fix is available for tensorflow — see the affected versions and patch details below.
Int overflow in `RaggedRangeOp` in Tensoflow
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-35940.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The RaggedRangOp function takes an argument limits that is eventually used to construct a TensorShape as an int64. If limits is a very large float, it can overflow when converted to an int64. This triggers an InvalidArgument but also throws an abort signal that crashes the program.
import tensorflow as tf
tf.raw_ops.RaggedRange(starts=[1.1,0.1],limits=[10.0,1e20],deltas=[1,1])
Patches
We have patched the issue in GitHub commit 37cefa91bee4eace55715eeef43720b958a01192.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Jingyi Shi.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.7.2pip install --upgrade 'tensorflow==2.7.2' |
| 🐍PyPI | tensorflow | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow==2.8.1' |
| 🐍PyPI | tensorflow | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow==2.9.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.7.2pip install --upgrade 'tensorflow-cpu==2.7.2' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow-cpu==2.8.1' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.9.0&&< 2.9.1 | 2.9.1pip install --upgrade 'tensorflow-cpu==2.9.1' |
Affected Products
tensorflowgoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35940 is resolved across your whole dependency graph.
Workarounds
Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.
Frequently Asked Questions
Is CVE-2022-35940 in your dependencies?
Find it across PyPI, including transitive dependencies.