CVE-2022-35921 is a low-severity (CVSS 3.5) Improper Privilege Management vulnerability in fof/byobu. A fix is available for fof/byobu — see the affected versions and patch details below.
User preference to prevent private discussions not respected in fof/byobu
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-35921.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
fof/byobuReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Users electing to prevent others starting private discussions with themselves.
Please note that admins and others with appropriate permissions can always bypass this preference, as was the case before.
Patches
Users of Byobu should update the extension to version 1.1.7, where this has been patched. This version is only supported on v1.2.0 and later of Flarum Core.
Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed.
Workarounds
There are no workarounds for this issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | fof/byobu | ≥ 0.3.0-beta.2&&< 1.1.7 | 1.1.7composer require fof/byobu:^1.1.7 |
Affected Products
byobufriendsofflarumDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fof/byobu, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update fof/byobu to 1.1.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35921 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2022-35921 in your dependencies?
Find it across Packagist, including transitive dependencies.