NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2022-35410 — mat2

HIGH

CVE-2022-35410 is a high-severity (CVSS 7.5) Path Traversal vulnerability in mat2. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for mat2 — see the affected versions and patch details below.

mat2 before 0.13.0 allows directory traversal during the ZIP archive cleaning process.

Also known asGHSA-f33p-9287-h552PYSEC-2022-223
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.95%1.90%2.84%0.4%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mat2

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

mat2 (aka metadata anonymisation toolkit) before 0.13.0 allows ../ directory traversal during the ZIP archive cleaning process. This primarily affects mat2 web instances, in which clients could obtain sensitive information via a crafted archive.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImat2all versions0.13.0pip install --upgrade 'mat2==0.13.0'

Affected Products

2 products · 3 configurations
Application
mat20xacab
< 0.13.0
range
OS
debian linuxdebian
2 versions
10.011.0
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mat2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mat2 to 0.13.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-35410 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

mat2 (aka metadata anonymisation toolkit) before 0.13.0 allows ../ directory traversal during the ZIP archive cleaning process. This primarily affects mat2 web instances, in which clients could obtain sensitive information via a crafted archive.
O3 Security · Impact-Aware SCA

Is CVE-2022-35410 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-35410: mat2 Path Traversal — Fixed in 0.13.0