NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-3517 — minimatch

HIGHFix: isaacs/minimatch@a8763f4

CVE-2022-3517 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in minimatch. A fix is available for minimatch — see the affected versions and patch details below.

minimatch ReDoS vulnerability

Also known asGHSA-f8q6-p94x-37v3
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-3517.

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.94%1.88%2.82%0.5%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

13Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
minimatchnpm
953.5Mdownloads / week

Description

A vulnerability was found in the minimatch package. This flaw allows a Regular Expression Denial of Service (ReDoS) when calling the braceExpand function with specific arguments, resulting in a Denial of Service.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmminimatchall versions3.0.5npm install minimatch@3.0.5

Affected Products

3 products · 4 configurations
OS
debian linuxdebian
1 version
10.0
OS
fedorafedoraproject
2 versions
3637
Application
minimatchminimatch_project
< 3.0.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for minimatch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update minimatch to 3.0.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-3517 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Migration Toolkit for Runtimes 1 on RHEL 8nodejs-minimatchRHSA-2023:0471
Red Hat Enterprise Linux 8nodejs:18-8070020221118123310.bd1311edRHSA-2022:8833
Red Hat Enterprise Linux 8nodejs:16-8070020221207164159.bd1311edRHSA-2022:9073
Red Hat Enterprise Linux 8nodejs:14-8070020221212161539.bd1311edRHSA-2023:0050
Red Hat Enterprise Linux 8nodejs:14-8070020230306170042.bd1311edRHSA-2023:1743
Red Hat Enterprise Linux 8.4 Extended Update Supportnodejs:14-8040020230306170312.522a0ee4RHSA-2023:1533
Red Hat Enterprise Linux 8.6 Extended Update Supportnodejs:14-8060020230306170237.ad008a3aRHSA-2023:1742
Red Hat Enterprise Linux 9nodejs:18-9010020221118120946.rhel9RHSA-2022:8832

Frequently Asked Questions

A vulnerability was found in the minimatch package. This flaw allows a Regular Expression Denial of Service (ReDoS) when calling the braceExpand function with specific arguments, resulting in a Denial of Service.
O3 Security · Impact-Aware SCA

Is CVE-2022-3517 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-3517: minimatch DoS — Fixed in 3.0.5