CVE-2022-33154 — schema
MEDIUMCVE-2022-33154 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in brotkrueml/schema. A fix is available for brotkrueml/schema — see the affected versions and patch details below.
brotkrueml/schema fails to properly encode user input for output in HTML context, leading to XSS
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
brotkrueml/schema🐘brotkrueml/schemaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | brotkrueml/schema | ≥ 2.0.0&&< 2.5.1 | 2.5.1composer require brotkrueml/schema:^2.5.1 |
| 🐘Packagist | brotkrueml/schema | all versions | 1.13.1composer require brotkrueml/schema:^1.13.1 |
Affected Products
schemaschema_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for brotkrueml/schema, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update brotkrueml/schema to 2.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-33154 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-33154 in your dependencies?
Find it across Packagist, including transitive dependencies.