CVE-2022-32173 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in OrchardCore. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for OrchardCore — see the affected versions and patch details below.
OrchardCore - HTML Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
OrchardCoreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
OrchardCore versions starting with 1.0.0-rc1-11259 and prior to 1.4.0 are vulnerable to HTML injection. The vulnerability allows an authenticated user with an editor security role to inject a persistent HTML modal dialog component into the dashboard that will affect admin users. Version 1.4.0 contains a patch.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | OrchardCore | ≥ 1.0.0-rc1-11259&&< 1.4.0 | 1.4.0dotnet add package OrchardCore --version 1.4.0 |
Affected Products
orchardcoreorchardcoreResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for OrchardCore, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update OrchardCore to 1.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-32173 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-32173 in your dependencies?
Find it across NuGet, including transitive dependencies.