NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2022-31799 — bottle

CRITICALFix: bottlepy/bottle@a2b0ee6

CVE-2022-31799 is a critical-severity (CVSS 9.8) CWE-755 vulnerability in bottle. A fix is available for bottle — see the affected versions and patch details below.

Denial of service in bottle

Also known asGHSA-xhp9-4947-rq78PYSEC-2022-227
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.89%1.79%2.68%0.3%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍bottle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Bottle before 0.12.20 mishandles errors during early request binding.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIbottleall versions0.12.20pip install --upgrade 'bottle==0.12.20'

Affected Products

3 products · 6 configurations
Application
bottlebottlepy
< 0.12.20
range
OS
debian linuxdebian
3 versions
9.010.011.0
OS
fedorafedoraproject
2 versions
3536

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bottle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bottle to 0.12.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31799 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Bottle before 0.12.20 mishandles errors during early request binding.
O3 Security · Impact-Aware SCA

Is CVE-2022-31799 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-31799: bottle — Fixed in 0.12.20