NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2022-31692 — spring-security-core

CRITICAL

CVE-2022-31692 is a critical-severity (CVSS 9.8) CWE-639 vulnerability in org.springframework.security:spring-security-core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.springframework.security:spring-security-core — see the affected versions and patch details below.

Spring Security authorization rules can be bypassed via forward or include dispatcher types

Also known asGHSA-mmmh-wcxm-2wr4
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31692.

EPSS Exploitation Probability

via FIRST.org ↗
4.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
2.24%4.35%6.46%8.58%7.4%4.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Spring Security, versions 5.7 prior to 5.7.5 and 5.6 prior to 5.6.9 could be susceptible to authorization rules bypass via forward or include dispatcher types. Specifically, an application is vulnerable when all of the following are true: The application expects that Spring Security applies security to forward and include dispatcher types. The application uses the AuthorizationFilter either manually or via the authorizeHttpRequests() method. The application configures the FilterChainProxy to apply to forward and/or include requests (e.g. spring.security.filter.dispatcher-types = request, error, async, forward, include). The application may forward or include the request to a higher privilege-secured endpoint.The application configures Spring Security to apply to every dispatcher type via authorizeHttpRequests().shouldFilterAllDispatcherTypes(true)

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.security:spring-security-core≥ 5.7.0&&< 5.7.55.7.5org.springframework.security:spring-security-core:5.7.5
☕Mavenorg.springframework.security:spring-security-core≥ 5.6.0&&< 5.6.95.6.9org.springframework.security:spring-security-core:5.6.9

Affected Products

2 products · 4 configurations
Application
active iq unified managernetapp
all
Application
spring securityvmware
≥ 5.7.0 && < 5.7.5
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.security:spring-security-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.security:spring-security-core to 5.7.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31692 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Fuse 7.12spring-securityRHSA-2023:3954
Red Hat OpenShift Container Platform 4.10jenkins-0:2.387.1.1680701869-1.el8RHSA-2023:1655

Frequently Asked Questions

Spring Security, versions 5.7 prior to 5.7.5 and 5.6 prior to 5.6.9 could be susceptible to authorization rules bypass via forward or include dispatcher types. Specifically, an application is vulnerable when all of the following are true: The application expects that Spring Security applies security to forward and include dispatcher types. The application uses the AuthorizationFilter either manually or via the authorizeHttpRequests() method. The application configures the FilterChainProxy to apply to forward and/or include requests (e.g. spring.security.filter.dispatcher-types = request, error
O3 Security · Impact-Aware SCA

Is CVE-2022-31692 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-31692: spring-security-core — Fixed in 5.7.5