NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
LOW severity

CVE-2026-22746 — spring-security-core

LOW

CVE-2026-22746 is a low-severity (CVSS 3.7) CWE-208 vulnerability in org.springframework.security:spring-security-core. A fix is available for org.springframework.security:spring-security-core — see the affected versions and patch details below.

User Attribute Enumeration when Using DaoAuthenticationProvider

Also known asGHSA-vxf7-qj7q-83fh
Published
Updated
Affected
6 pkgs
Patched
2 / 6
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-22746.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs12th percentile — riskier than 12% of all scored CVEsHighest risk
0.00%0.24%0.48%0.71%0.1%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Vulnerability in Spring Spring Security. If an application is using the UserDetails#isEnabled, #isAccountNonExpired, or #isAccountNonLocked user attributes, to enable, expire, or lock users, then DaoAuthenticationProvider's timing attack defense can be bypassed for users who are disabled, expired, or locked. This issue affects Spring Security: from 5.7.0 through 5.7.22, from 5.8.0 through 5.8.24, from 6.3.0 through 6.3.15, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.

Affected Packages

6 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.security:spring-security-core≥ 5.7.0No fix
☕Mavenorg.springframework.security:spring-security-core≥ 5.8.0No fix
☕Mavenorg.springframework.security:spring-security-core≥ 6.3.0No fix
☕Mavenorg.springframework.security:spring-security-core≥ 6.4.0No fix
☕Mavenorg.springframework.security:spring-security-core≥ 6.5.0&&< 6.5.106.5.10org.springframework.security:spring-security-core:6.5.10
☕Mavenorg.springframework.security:spring-security-core≥ 7.0.0&&< 7.0.57.0.5org.springframework.security:spring-security-core:7.0.5

Affected Products

1 product · 6 configurations
Application
spring securityvmware
≥ 7.0.0 && < 7.0.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.security:spring-security-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2026-22746; check the affected-versions list above or the advisory for the patched release of org.springframework.security:spring-security-core, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Vulnerability in Spring Spring Security. If an application is using the UserDetails#isEnabled, #isAccountNonExpired, or #isAccountNonLocked user attributes, to enable, expire, or lock users, then DaoAuthenticationProvider's timing attack defense can be bypassed for users who are disabled, expired, or locked. This issue affects Spring Security: from 5.7.0 through 5.7.22, from 5.8.0 through 5.8.24, from 6.3.0 through 6.3.15, from 6.5.0 through 6.5.9, from 7.0.0 through 7.0.4.
O3 Security · Impact-Aware SCA

Is CVE-2026-22746 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2026-22746: spring-security-core — Fixed in 6.5.10