CVE-2022-31077 is a medium-severity (CVSS 4) NULL Pointer Dereference vulnerability in github.com/kubeedge/kubeedge. A fix is available for github.com/kubeedge/kubeedge — see the affected versions and patch details below.
Malicious response from KubeEdge can crash CSI Driver controller server
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31077.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/kubeedge/kubeedge🐹github.com/kubeedge/kubeedgeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A malicious message response from KubeEdge can crash the CSI Driver controller server by triggering a nil-pointer dereference panic. As a consequence, the CSI Driver controller will be in denial of service. An attacker would already need to be an authenticated user of the Cloud, and only when the authenticated user launches the csidriver then CloudCore may be attacked.
Patches
This bug has been fixed in Kubeedge 1.11.0, 1.10.1, and 1.9.3. Users should update to these versions to resolve the issue.
Workarounds
At the time of writing, no workaround exists.
References
NA
Credits
Thanks David Korczynski and Adam Korczynski of ADA Logics for responsibly disclosing this issue in accordance with the kubeedge security policy during a security audit sponsored by CNCF and facilitated by OSTIF.
For more information
If you have any questions or comments about this advisory:
- Open an issue in KubeEdge repo
- To make a vulnerability report, email your vulnerability to the private [email protected] list with the security details and the details expected for KubeEdge bug reports.
Notes: This vulnerability was found by fuzzing KubeEdge by way of OSS-Fuzz.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/kubeedge/kubeedge | ≥ 1.10.0&&< 1.10.1 | 1.10.1go get github.com/kubeedge/kubeedge@v1.10.1 |
| 🐹Go | github.com/kubeedge/kubeedge | all versions | 1.9.3go get github.com/kubeedge/kubeedge@v1.9.3 |
Affected Products
kubeedgelinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kubeedge/kubeedge, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/kubeedge/kubeedge to 1.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31077 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2022-31077 in your dependencies?
Find it across Go, including transitive dependencies.