CVE-2022-31078 — kubeedge
MEDIUMCVE-2022-31078 is a medium-severity (CVSS 4.4) Uncontrolled Resource Consumption vulnerability in github.com/kubeedge/kubeedge. A fix is available for github.com/kubeedge/kubeedge — see the affected versions and patch details below.
KubeEdge CloudCore Router memory exhaustion
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31078.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/kubeedge/kubeedge🐹github.com/kubeedge/kubeedge🐹github.com/kubeedge/kubeedgeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The CloudCore Router does not impose a limit on the size of responses to requests made by the REST handler. An attacker could use this weakness to make a request that will return an HTTP response with a large body and cause DoS of CloudCore. In the HTTP Handler API, the rest handler makes a request to a pre-specified handle. The handle will return an HTTP response that is then read into memory. The consequence of the exhaustion is that CloudCore will be in a denial of service.
Only an authenticated user of the cloud can make an attack. It will be affected only when users enable router module in the config file cloudcore.yaml as below.
modules:
...
router:
enable: true
Patches
This bug has been fixed in Kubeedge 1.11.1, 1.10.2, 1.9.4. Users should update to these versions to resolve the issue.
Workarounds
Disable the router module in the config file cloudcore.yaml.
References
NA
Credits
Thanks David Korczynski and Adam Korczynski of ADA Logics for responsibly disclosing this issue in accordance with the kubeedge security policy during a security audit sponsored by CNCF and facilitated by OSTIF.
For more information
If you have any questions or comments about this advisory:
- Open an issue in KubeEdge repo
- To make a vulnerability report, email your vulnerability to the private [email protected] list with the security details and the details expected for KubeEdge bug reports.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/kubeedge/kubeedge | ≥ 1.11.0&&< 1.11.1 | 1.11.1go get github.com/kubeedge/kubeedge@v1.11.1 |
| 🐹Go | github.com/kubeedge/kubeedge | ≥ 1.10.0&&< 1.10.2 | 1.10.2go get github.com/kubeedge/kubeedge@v1.10.2 |
| 🐹Go | github.com/kubeedge/kubeedge | all versions | 1.9.4go get github.com/kubeedge/kubeedge@v1.9.4 |
Affected Products
kubeedgelinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/kubeedge/kubeedge, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/kubeedge/kubeedge to 1.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31078 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2022-31078 in your dependencies?
Find it across Go, including transitive dependencies.