NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-31027 — oauthenticator

MEDIUMFix: jupyterhub/oauthenticator@5cd2d18

CVE-2022-31027 is a medium-severity (CVSS 4.2) CWE-639 vulnerability in oauthenticator. A fix is available for oauthenticator — see the affected versions and patch details below.

Authorization Bypass Through User-Controlled Key when using CILogonOAuthenticator in oauthenticator

Also known asGHSA-r7v4-jwx9-wx43PYSEC-2022-206
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-31027.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.33%0.65%0.97%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍oauthenticator

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Background

CILogon is a federated auth provider that allows users to authenticate themselves via a number of Identity Providers (IdP), focused primarily on educational and research institutions (such as Universities). More traditional and open IdPs such as GitHub, ORCID, Google, Microsoft, etc are also supported.

CILogonOAuthenticator is provided by the OAuthenticator package, and lets users log in to a JupyterHub via CILogon. This is primarily used to restrict a JupyterHub only to users of a given institute. The allowed_idps configuration trait of CILogonOAuthenticator is documented to be a list of domains that indicate the institutions whose users are authorized to access this JupyterHub. This authorization is validated by ensuring that the email field provided to us by CILogon has a domain that matches one of the domains listed in allowed_idps.

Impact

If allowed_idps contains berkeley.edu, you might expect only users with valid current credentials provided by University of California, Berkeley to be able to access the JupyterHub. However, CILogonOAuthenticator does not verify which provider is used by the user to login, only the email address provided. So a user can login with a GitHub account that has email set to <something>@berkeley.edu, and that will be treated exactly the same as someone logging in using the UC Berkeley official Identity Provider. This has two consequences:

  1. Since GitHub (and most other providers we tested) only require you to verify your email once, a user can access a JupyterHub even if their access to the institution's IdP has been revoked or expired.
  2. CILogon supports hundreds of identity providers - if even one of them allows users to set any email ids without verifying, that can be used to impersonate any user on any other identity provider! While CILogon itself has a stellar security record, this particular method of doing authorization means an attacker would only need to compromise a single identity provider to compromise all of CILogon

We currently do not know of any identity provider that provides unverified email addresses to CILogon, so this is not a severe known vulnerability. However, there are hundreds of IdPs, and we could not try them all.

Patches

This patch makes a breaking change in how allowed_idps is interpreted. It's no longer a list of domains, but configuration representing the EntityID of the IdPs that are allowed, picked from the list maintained by CILogon. So instead of berkeley.edu, you would specify urn:mace:incommon:berkeley.edu to allow logins from users currently with berkeley.edu accounts. GitHub users with a verified berkeley.edu email will no longer be allowed to log in.

For details on how to transition your CILogonOAuthenticator configuration to the patched version 15.0.0 or above, see the migration documentation.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIoauthenticatorall versions15.0.0pip install --upgrade 'oauthenticator==15.0.0'

Affected Products

1 product · 1 configurations
Application
oauthenticatorjupyter
< 15.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for oauthenticator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update oauthenticator to 15.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-31027 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

# Background CILogon is a federated auth provider that allows users to authenticate themselves via a number of Identity Providers (IdP), focused primarily on educational and research institutions (such as Universities). More traditional and open IdPs such as GitHub, ORCID, Google, Microsoft, etc are also supported. CILogonOAuthenticator is provided by the OAuthenticator package, and lets users log in to a JupyterHub via CILogon. This is primarily used to restrict a JupyterHub only to users of a given institute. The allowed_idps configuration trait of CILogonOAuthenticator is documented to be
O3 Security · Impact-Aware SCA

Is CVE-2022-31027 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-31027: oauthenticator — Fixed in 15.0.0