CVE-2020-26250 is a medium-severity (CVSS 6.3) CWE-863 vulnerability in oauthenticator. A fix is available for oauthenticator — see the affected versions and patch details below.
Base class whitelist configuration ignored in OAuthenticator
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
oauthenticatorReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
What goes wrong?
The deprecated (in jupyterhub 1.2) configuration Authenticator.whitelist, which should be transparently mapped to Authenticator.allowed_users with a warning, is instead ignored by OAuthenticator classes, resulting in the same behavior as if this configuration has not been set. If this is the only mechanism of authorization restriction (i.e. no group or team restrictions in configuration) then all authenticated users will be allowed. Provider-based restrictions, including deprecated values such as GitHubOAuthenticator.org_whitelist are not affected.
Who is impacted?
All users of OAuthenticator 0.12.0 and 0.12.1 with JupyterHub 1.2 (JupyterHub Helm chart 0.10.0-0.10.5) who use the admin.whitelist.users configuration in the jupyterhub helm chart or the c.Authenticator.whitelist configuration directly. Users of other deprecated configuration, e.g. c.GitHubOAuthenticator.team_whitelist are not affected.
If you see a log line like this and expect a specific list of allowed usernames:
[I 2020-11-27 16:51:54.528 JupyterHub app:1717] Not using allowed_users. Any authenticated user will be allowed.
you are likely affected.
Patches
- Replacing deprecated
c.Authenticator.whitelist = ...withc.Authenticator.allowed_users = ...avoids the issue. - Update oauthenticator to 0.12.2
- Update jupyterhub helm chart to 0.10.6
If any users have been authorized during this time who should not have been, they must be deleted via the API or admin interface, per the documentation.
Workarounds
Replacing c.Authenticator.whitelist = ... with c.Authenticator.allowed_users = ... avoids the issue.
In the jupyterhub helm chart prior to 0.10.6, this can be done via hub.extraConfig:
auth:
allowedUsers:
- user1
- user2
hub:
extraConfig:
allowedUsers: |
# set new field not exposed in helm chart < 0.10.6
set_config_if_not_none(c.Authenticator, "allowed_users", "auth.allowedUsers")
For more information
If you have any questions or comments about this advisory:
- Open a thread on the Jupyter forum
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | oauthenticator | ≥ 0.12.0&&< 0.12.2 | 0.12.2pip install --upgrade 'oauthenticator==0.12.2' |
Affected Products
oauthenticatorjupyterDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for oauthenticator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update oauthenticator to 0.12.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-26250 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2020-26250 in your dependencies?
Find it across PyPI, including transitive dependencies.