CVE-2022-30324 — nomad
CRITICALCVE-2022-30324 is a critical-severity (CVSS 9.8) vulnerability in github.com/hashicorp/nomad. A fix is available for github.com/hashicorp/nomad — see the affected versions and patch details below.
Privilege escalation in Hashicorp Nomad
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/hashicorp/nomad🐹github.com/hashicorp/nomad🐹github.com/hashicorp/nomadReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
HashiCorp Nomad and Nomad Enterprise version 0.2.0 up to 1.3.0 were impacted by go-getter vulnerabilities enabling privilege escalation through the artifact stanza in submitted jobs onto the client agent host. Fixed in 1.1.14, 1.2.8, and 1.3.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/hashicorp/nomad | ≥ 0.2.0&&< 1.1.14 | 1.1.14go get github.com/hashicorp/nomad@v1.1.14 |
| 🐹Go | github.com/hashicorp/nomad | ≥ 1.2.0&&< 1.2.8 | 1.2.8go get github.com/hashicorp/nomad@v1.2.8 |
| 🐹Go | github.com/hashicorp/nomad | ≥ 1.3.0&&< 1.3.1 | 1.3.1go get github.com/hashicorp/nomad@v1.3.1 |
Affected Products
nomadhashicorpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hashicorp/nomad, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/hashicorp/nomad to 1.1.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-30324 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2022-30324 in your dependencies?
Find it across Go, including transitive dependencies.