CVE-2022-29258 is a high-severity (CVSS 7.4) CWE-80 vulnerability in org.xwiki.platform:xwiki-platform-filter-ui. A fix is available for org.xwiki.platform:xwiki-platform-filter-ui — see the affected versions and patch details below.
Cross-site Scripting in Filter Stream Converter Application in XWiki Platform
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-29258.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-filter-ui☕org.xwiki.platform:xwiki-platform-filter-ui☕org.xwiki.platform:xwiki-platform-filter-uiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
XWiki Platform Filter UI provides a generic user interface to convert from a XWiki Filter input stream to an output stream with settings for each stream. Starting with versions 6.0-milestone-2 and 5.4.4 and prior to versions 12.10.11, 14.0-rc-1, 13.4.7, and 13.10.3, XWiki Platform Filter UI contains a possible cross-site scripting vector in the Filter.FilterStreamDescriptorForm wiki page related to pretty much all the form fields printed in the home page of the application. The issue is patched in versions 12.10.11, 14.0-rc-1, 13.4.7, and 13.10.3. The easiest workaround is to edit the wiki page Filter.FilterStreamDescriptorForm (with wiki editor) according to the instructions in the GitHub Security Advisory.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-filter-ui | ≥ 5.4.4&&< 12.10.11 | 12.10.11org.xwiki.platform:xwiki-platform-filter-ui:12.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-filter-ui | ≥ 13.0.0&&< 13.4.7 | 13.4.7org.xwiki.platform:xwiki-platform-filter-ui:13.4.7 |
| ☕Maven | org.xwiki.platform:xwiki-platform-filter-ui | ≥ 13.5.0&&< 13.10.3 | 13.10.3org.xwiki.platform:xwiki-platform-filter-ui:13.10.3 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-filter-ui, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-filter-ui to 12.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29258 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-29258 in your dependencies?
Find it across Maven, including transitive dependencies.