NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-29204 — tensorflow

MEDIUMFix: tensorflow/tensorflow@20cb187

CVE-2022-29204 is a medium-severity (CVSS 5.5) Improper Input Validation vulnerability in tensorflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tensorflow — see the affected versions and patch details below.

Missing validation causes denial of service in TensorFlow via `Conv3DBackpropFilterV2`

Also known asBIT-tensorflow-2022-29204GHSA-hx9q-2mx4-m4pgPYSEC-2026-1010PYSEC-2026-3203PYSEC-2026-3342
Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-29204.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs29th percentile — riskier than 29% of all scored CVEsHighest risk
0.00%0.28%0.57%0.85%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐍tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The implementation of tf.raw_ops.UnsortedSegmentJoin does not fully validate the input arguments. This results in a CHECK-failure which can be used to trigger a denial of service attack:

import tensorflow as tf

tf.strings.unsorted_segment_join(
  inputs=['123'],
  segment_ids=[0],
  num_segments=-1)

The code assumes num_segments is a positive scalar but there is no validation:

const Tensor& num_segments_tensor = context->input(2);
auto num_segments = num_segments_tensor.scalar<NUM_SEGMENTS_TYPE>()();
// ...
Tensor* output_tensor = nullptr;
TensorShape output_shape =
    GetOutputShape(input_shape, segment_id_shape, num_segments);

Since this value is used to allocate the output tensor, a negative value would result in a CHECK-failure (assertion failure), as per TFSA-2021-198.

Patches

We have patched the issue in GitHub commit 84563f265f28b3c36a15335c8b005d405260e943 and GitHub commit 20cb18724b0bf6c09071a3f53434c4eec53cc147.

The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range.

For more information

Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.

Attribution

This vulnerability has been reported externally via a GitHub issue.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItensorflowall versions2.6.4pip install --upgrade 'tensorflow==2.6.4'
🐍PyPItensorflow≥ 2.7.0&&< 2.7.22.7.2pip install --upgrade 'tensorflow==2.7.2'
🐍PyPItensorflow≥ 2.8.0&&< 2.8.12.8.1pip install --upgrade 'tensorflow==2.8.1'
🐍PyPItensorflow-cpuall versions2.6.4pip install --upgrade 'tensorflow-cpu==2.6.4'
🐍PyPItensorflow-cpu≥ 2.7.0&&< 2.7.22.7.2pip install --upgrade 'tensorflow-cpu==2.7.2'
🐍PyPItensorflow-cpu≥ 2.8.0&&< 2.8.12.8.1pip install --upgrade 'tensorflow-cpu==2.8.1'

Affected Products

1 product · 9 configurations
Application
tensorflowgoogle
≥ 2.7.0 && < 2.7.2
3 versions
2.7.02.8.02.9.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tensorflow to 2.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29204 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact The implementation of [`tf.raw_ops.UnsortedSegmentJoin`](https://github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/core/kernels/unsorted_segment_join_op.cc#L83-L148) does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack: ```python import tensorflow as tf tf.strings.unsorted_segment_join( inputs=['123'], segment_ids=[0], num_segments=-1) ``` The code assumes `num_segments` is a positive scalar but there is no validation: ```cc const Tensor& num_segments_t
O3 Security · Impact-Aware SCA

Is CVE-2022-29204 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-29204: tensorflow DoS — Fixed in 2.6.4