CVE-2022-29192 is a medium-severity (CVSS 5.5) Improper Input Validation vulnerability in tensorflow. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for tensorflow — see the affected versions and patch details below.
Missing validation crashes `QuantizeAndDequantizeV4Grad` in TensorFlow
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-29192.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tensorflow🐍tensorflow🐍tensorflow🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-cpu🐍tensorflow-gpu🐍tensorflow-gpu+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The implementation of tf.raw_ops.QuantizeAndDequantizeV4Grad does not fully validate the input arguments. This results in a CHECK-failure which can be used to trigger a denial of service attack:
import tensorflow as tf
tf.raw_ops.QuantizeAndDequantizeV4Grad(
gradients=tf.constant(1, shape=[2,2], dtype=tf.float64),
input=tf.constant(1, shape=[2,2], dtype=tf.float64),
input_min=tf.constant([], shape=[0], dtype=tf.float64),
input_max=tf.constant(-10, shape=[], dtype=tf.float64),
axis=-1)
The code assumes input_min and input_max are scalars but there is no validation for this.
Patches
We have patched the issue in GitHub commit 098e7762d909bac47ce1dbabe6dfd06294cb9d58.
The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Neophytos Christou from Secure Systems Lab at Brown University.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tensorflow | all versions | 2.6.4pip install --upgrade 'tensorflow==2.6.4' |
| 🐍PyPI | tensorflow | ≥ 2.7.0&&< 2.7.2 | 2.7.2pip install --upgrade 'tensorflow==2.7.2' |
| 🐍PyPI | tensorflow | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow==2.8.1' |
| 🐍PyPI | tensorflow-cpu | all versions | 2.6.4pip install --upgrade 'tensorflow-cpu==2.6.4' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.7.0&&< 2.7.2 | 2.7.2pip install --upgrade 'tensorflow-cpu==2.7.2' |
| 🐍PyPI | tensorflow-cpu | ≥ 2.8.0&&< 2.8.1 | 2.8.1pip install --upgrade 'tensorflow-cpu==2.8.1' |
Affected Products
tensorflowgoogleResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tensorflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tensorflow to 2.6.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-29192 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2022-29192 in your dependencies?
Find it across PyPI, including transitive dependencies.