NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2022-26260 — simple-plist

CRITICALFix: wollardj/simple-plist@670e22f

CVE-2022-26260 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in simple-plist. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for simple-plist — see the affected versions and patch details below.

Prototype Pollution in simple-plist

Also known asGHSA-gff7-g5r8-mg8m
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.00%0.61%1.22%1.83%0.3%1.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

270other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
simple-plistnpm
18.8Mdownloads / week

Description

Simple-Plist v1.3.0 was discovered to contain a prototype pollution vulnerability via .parse().

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmsimple-plistall versions1.3.1npm install simple-plist@1.3.1

Affected Products

1 product · 1 configurations
Application
simple-plistsimple-plist_project
1 version
1.3.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for simple-plist, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update simple-plist to 1.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-26260 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Simple-Plist v1.3.0 was discovered to contain a prototype pollution vulnerability via .parse().
O3 Security · Impact-Aware SCA

Is CVE-2022-26260 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-26260: simple-plist — Fixed in 1.3.1