NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-25907 — ts-deepmerge

HIGHFix: voodoocreation/ts-deepmerge@9be5148

CVE-2022-25907 is a high-severity (CVSS 7.5) CWE-1321 vulnerability in ts-deepmerge. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for ts-deepmerge — see the affected versions and patch details below.

Prototype Pollution

Also known asGHSA-7qqq-gh2f-wq76
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.80%1.61%2.41%0.2%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

367other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ts-deepmergenpm
5.3Mdownloads / week

Description

The package ts-deepmerge before version 2.0.2 is vulnerable to Prototype Pollution due to missing sanitization of the merge function.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmts-deepmergeall versions2.0.2npm install ts-deepmerge@2.0.2

Affected Products

1 product · 1 configurations
Application
typescript deep mergetypescript_deep_merge_project
< 2.0.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ts-deepmerge, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ts-deepmerge to 2.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25907 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The package ts-deepmerge before version 2.0.2 is vulnerable to Prototype Pollution due to missing sanitization of the `merge` function.
O3 Security · Impact-Aware SCA

Is CVE-2022-25907 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-25907: ts-deepmerge — Fixed in 2.0.2