NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2022-25866 — git-php

HIGHFix: czproject/git-php@5e82d54

CVE-2022-25866 is a high-severity (CVSS 8.1) CWE-88 vulnerability in czproject/git-php. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for czproject/git-php — see the affected versions and patch details below.

Command Injection

Also known asGHSA-3xpw-vhmv-cw7hSNYK-PHP-CZPROJECTGITPHP-2421349
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
1.43%2.43%3.44%4.45%2.0%3.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘czproject/git-php

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The package czproject/git-php before 4.0.3 are vulnerable to Command Injection via git argument injection. When calling the isRemoteUrlReadable($url, array $refs = NULL) function, both the url and refs parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistczproject/git-phpall versions4.0.3composer require czproject/git-php:^4.0.3

Affected Products

1 product · 1 configurations
Application
git-phpgit-php_project
< 4.0.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for czproject/git-php, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update czproject/git-php to 4.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25866 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The package czproject/git-php before 4.0.3 are vulnerable to Command Injection via git argument injection. When calling the isRemoteUrlReadable($url, array $refs = NULL) function, both the url and refs parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
O3 Security · Impact-Aware SCA

Is CVE-2022-25866 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-25866: git-php — Fixed in 4.0.3