NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-25854 — @yaireo/tagify

MEDIUMFix: yairEO/tagify@198c045

CVE-2022-25854 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in @yaireo/tagify. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for @yaireo/tagify — see the affected versions and patch details below.

Cross-site Scripting (XSS)

Also known asGHSA-pxpf-v376-7xx5SNYK-JS-YAIREOTAGIFY-2404358
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs63th percentile — riskier than 63% of all scored CVEsHighest risk
0.30%0.70%1.09%1.49%0.8%1.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

62other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@yaireo/tagifynpm
184Kdownloads / week

Description

This affects the package @yaireo/tagify before 4.9.8. The package is used for rendering UI components inside the input or text fields, and an attacker can pass a malicious placeholder value to it to fire the cross-site scripting (XSS) payload.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@yaireo/tagifyall versions4.9.8npm install @yaireo/tagify@4.9.8

Affected Products

1 product · 1 configurations
Application
tagifytagify_project
< 4.9.8
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @yaireo/tagify, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @yaireo/tagify to 4.9.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25854 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

This affects the package @yaireo/tagify before 4.9.8. The package is used for rendering UI components inside the input or text fields, and an attacker can pass a malicious placeholder value to it to fire the cross-site scripting (XSS) payload.
O3 Security · Impact-Aware SCA

Is CVE-2022-25854 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-25854: @yaireo/tagify XSS — Fixed in 4.9.8