NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2022-25850 — proxyscotch

HIGHFix: hoppscotch/proxyscotch@de67380

CVE-2022-25850 is a high-severity (CVSS 7.5) Server-Side Request Forgery (SSRF) vulnerability in github.com/hoppscotch/proxyscotch. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/hoppscotch/proxyscotch — see the affected versions and patch details below.

Server-side Request Forgery (SSRF)

Also known asGHSA-5hjh-c26m-xw8wSNYK-GOLANG-GITHUBCOMHOPPSCOTCHPROXYSCOTCH-2435228
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.62%1.25%1.87%0.3%1.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/hoppscotch/proxyscotch

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

ProxyScotch is a simple proxy server created for hoppscotch.io. The package github.com/hoppscotch/proxyscotch before 1.0.0 are vulnerable to Server-side Request Forgery (SSRF) when interceptor mode is set to proxy. It occurs when an HTTP request is made by a backend server to an untrusted URL submitted by a user. It leads to a leakage of sensitive information from the server.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/hoppscotch/proxyscotchall versions1.0.0go get github.com/hoppscotch/proxyscotch@v1.0.0

Affected Products

1 product · 1 configurations
Application
proxyscotchproxyscotch_project
< 1.0.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/hoppscotch/proxyscotch, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/hoppscotch/proxyscotch to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25850 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

ProxyScotch is a simple proxy server created for hoppscotch.io. The package github.com/hoppscotch/proxyscotch before 1.0.0 are vulnerable to Server-side Request Forgery (SSRF) when interceptor mode is set to proxy. It occurs when an HTTP request is made by a backend server to an untrusted URL submitted by a user. It leads to a leakage of sensitive information from the server.
O3 Security · Impact-Aware SCA

Is CVE-2022-25850 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-25850: proxyscotch SSRF — Fixed in 1.0.0