NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-25777 — core

MEDIUMFix: mautic/mautic@b4b4ab5

CVE-2022-25777 is a medium-severity (CVSS 6.5) Server-Side Request Forgery (SSRF) vulnerability in mautic/core. A fix is available for mautic/core — see the affected versions and patch details below.

Server-Side Request Forgery in Asset section

Also known asGHSA-mgv8-w49f-822w
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-25777.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk
0.00%0.32%0.63%0.95%0.2%0.4%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘mautic/core🐘mautic/core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Prior to the patched version, an authenticated user of Mautic could read system files and access the internal addresses of the application due to a Server-Side Request Forgery (SSRF) vulnerability.

Patches

Update to 4.4.12 or 5.0.4

Workarounds

None

References

If you have any questions or comments about this advisory:

Email us at [email protected]

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmautic/core≥ 1.0.0-beta4&&< 4.4.124.4.12composer require mautic/core:^4.4.12
🐘Packagistmautic/core≥ 5.0.0-alpha&&< 5.0.45.0.4composer require mautic/core:^5.0.4

Affected Products

1 product · 8 configurations
Application
mauticacquia
≥ 5.0.0 && < 5.0.4
1 version
1.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mautic/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mautic/core to 4.4.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25777 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

### Impact Prior to the patched version, an authenticated user of Mautic could read system files and access the internal addresses of the application due to a Server-Side Request Forgery (SSRF) vulnerability. ### Patches Update to 4.4.12 or 5.0.4 ### Workarounds None ### References - https://owasp.org/Top10/A10_2021-Server-Side_Request_Forgery_%28SSRF%29/ If you have any questions or comments about this advisory: Email us at [[email protected]](mailto:[email protected])
O3 Security · Impact-Aware SCA

Is CVE-2022-25777 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-25777: core SSRF — Fixed in 4.4.12