CVE-2022-25772 is a critical-severity (CVSS 9.6) Cross-site Scripting (XSS) vulnerability in mautic/core. EPSS puts its 30-day exploitation probability at 63.0% (99th percentile). A fix is available for mautic/core — see the affected versions and patch details below.
Cross-site Scripting vulnerability in Mautic's tracking pixel functionality
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
mautic/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Mautic allows you to track open rates by using tracking pixels. The tracking information is stored together with extra metadata of the tracking request.
The output isn't sufficiently filtered when showing the metadata of the tracking information, which may lead to a vulnerable situation.
Patches
Please upgrade to 4.3.0
Workarounds
None.
References
- Internally tracked under MST-38
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | mautic/core | all versions | 4.3.0composer require mautic/core:^4.3.0 |
Affected Products
mauticacquiaDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mautic/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mautic/core to 4.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25772 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-25772 in your dependencies?
Find it across Packagist, including transitive dependencies.