NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2022-25770 — core

HIGHFix: mautic/mautic@73b18e9

CVE-2022-25770 is a high-severity (CVSS 7.8) Missing Authentication vulnerability in mautic/core. A fix is available for mautic/core — see the affected versions and patch details below.

Insufficient authentication in upgrade flow

Also known asGHSA-qf6m-6m4g-rmrc
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-25770.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs20th percentile — riskier than 20% of all scored CVEsHighest risk
0.00%0.27%0.53%0.80%0.3%0.3%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘mautic/core🐘mautic/core🐘mautic/core-lib🐘mautic/core-lib

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable

Patches

Please upgrade to 4.4.1 or 5.1.1 or later.

Workarounds

None.

For more information

If you have any questions or comments about this advisory:

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmautic/core≥ 1.0.0-beta3&&< 4.4.134.4.13composer require mautic/core:^4.4.13
🐘Packagistmautic/core≥ 5.0.0-alpha&&< 5.1.15.1.1composer require mautic/core:^5.1.1
🐘Packagistmautic/core-lib≥ 1.0.0-beta3&&< 4.4.134.4.13composer require mautic/core-lib:^4.4.13
🐘Packagistmautic/core-lib≥ 5.0.0-alpha&&< 5.1.15.1.1composer require mautic/core-lib:^5.1.1

Affected Products

1 product · 9 configurations
Application
mauticacquia
≥ 5.0.0 && < 5.1.1
1 version
1.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mautic/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mautic/core to 4.4.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25770 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

### Impact Mautic allows you to update the application via an upgrade script. The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation. This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable ### Patches Please upgrade to 4.4.1 or 5.1.1 or later. ### Workarounds None. ### For more information If you have any questions or comments about this advisory: * Email us at [[email protected]](mailto:[email protected])
O3 Security · Impact-Aware SCA

Is CVE-2022-25770 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-25770: core — Fixed in 4.4.13