NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-25766 — ungit

HIGHFix: FredrikNoren/ungit#1510

CVE-2022-25766 is a high-severity (CVSS 8.8) CWE-88 vulnerability in ungit. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for ungit — see the affected versions and patch details below.

Remote Code Execution (RCE)

Also known asGHSA-hf8c-xr89-vfm5SNYK-JS-UNGIT-2414099
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
34.5%probability of exploitation in next 30 days
Moderate Risk+0.24%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.00%14.5%29.1%43.6%4.2%34.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
ungitnpm
192downloads / week

Description

The package ungit before 1.5.20 are vulnerable to Remote Code Execution (RCE) via argument injection. The issue occurs when calling the /api/fetch endpoint. User controlled values (remote and ref) are passed to the git fetch command. By injecting some git options it was possible to get arbitrary command execution.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmungitall versions1.5.20npm install ungit@1.5.20

Affected Products

1 product · 1 configurations
Application
ungitungit_project
< 1.5.20
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ungit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ungit to 1.5.20 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25766 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The package ungit before 1.5.20 are vulnerable to Remote Code Execution (RCE) via argument injection. The issue occurs when calling the /api/fetch endpoint. User controlled values (remote and ref) are passed to the git fetch command. By injecting some git options it was possible to get arbitrary command execution.
O3 Security · Impact-Aware SCA

Is CVE-2022-25766 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-25766: ungit RCE — Fixed in 1.5.20