CVE-2022-25765 is a critical-severity (CVSS 9.8) remote code execution vulnerability in pdfkit. 13 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for pdfkit — see the affected versions and patch details below.
PDFKit vulnerable to Command Injection
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pdfkitReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
The package pdfkit is vulnerable to Command Injection where the URL is not properly sanitized.
Note: This issue was patched in 0.8.7.2, but the patch was discovered to be ineffective. The updated patch version is 0.8.7.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | pdfkit | all versions | 0.8.7.2bundle update pdfkit --conservative |
Affected Products
fedorafedoraprojectpdfkitpdfkit_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
The package pdfkit from 0.0.0 are vulnerable to Command Injection where …
Report on github.com
Report on github.com
Report on github.com
Report on github.com
Report on github.com
Report on github.com
Report on github.com
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pdfkit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pdfkit to 0.8.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25765 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2022-25765 in your dependencies?
Find it across RubyGems, including transitive dependencies.