NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

CVE-2013-1607 — pdfkit

CRITICAL

CVE-2013-1607 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in pdfkit. A fix is available for pdfkit — see the affected versions and patch details below.

PDFKit Improper Input Validation vulnerability

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.76%1.57%2.37%3.17%1.3%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎pdfkit

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemspdfkitall versions0.5.3bundle update pdfkit --conservative

Affected Products

1 product · 1 configurations
Application
pdfkitpdfkit_project
< 0.5.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pdfkit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pdfkit to 0.5.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2013-1607 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Ruby PDFKit gem prior to 0.5.3 has a Code Execution Vulnerability
O3 Security · Impact-Aware SCA

Is CVE-2013-1607 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2013-1607: pdfkit — Fixed in 0.5.3