NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2022-25568 — motioneye

HIGHFix: motioneye-project/motioneye@c60b64a

CVE-2022-25568 is a high-severity (CVSS 7.5) CWE-1188 vulnerability in motioneye. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for motioneye — see the affected versions and patch details below.

MotionEye allows attackers to access sensitive information

Also known asGHSA-2c7w-v459-cwgfPYSEC-2022-43141
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%85.3%6.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍motioneye

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

MotionEye v0.42.1 and below allows attackers to access sensitive information via a GET request to /config/list. To exploit this vulnerability, a regular user password must be unconfigured.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImotioneyeall versions0.43.1b1pip install --upgrade 'motioneye==0.43.1b1'

Affected Products

1 product · 1 configurations
Application
motioneyemotioneye_project
≤ 0.42.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for motioneye, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update motioneye to 0.43.1b1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25568 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

How to detect CVE-2022-25568

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2022-25568 -u https://target
Template
MotionEye Config Info Disclosure
Severity
high
Impact
Unauthenticated attackers can access sensitive MotionEye configuration data including upload passwords and network passwords through the /config/list endpoint when regular user authentication is not configured, potentially compromising camera systems and network access.
Remediation
Update MotionEye to version 0.42.2 or later and ensure regular user passwords are properly configured to restrict access.

Template by ProjectDiscovery nuclei-templates (DhiyaneshDK), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

MotionEye v0.42.1 and below allows attackers to access sensitive information via a GET request to /config/list. To exploit this vulnerability, a regular user password must be unconfigured.
O3 Security · Impact-Aware SCA

Is CVE-2022-25568 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-25568: motioneye — Fixed in 0.43.1b1