NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2022-2529 — goflow

HIGHFix: cloudflare/goflow@2b94619

CVE-2022-2529 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in github.com/cloudflare/goflow/v3. A fix is available for github.com/cloudflare/goflow/v3 — see the affected versions and patch details below.

Multiple DoS Attack Vectors in sflow packet handling

Also known asGHSA-9rpw-2h95-666cGO-2022-1032
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 26, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-2529.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.07%0.54%1.01%1.47%0.7%1.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/cloudflare/goflow/v3

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The sflow decode package prior to version 3.4.4 does not employ sufficient packet sanitisation which can lead to a denial of service attack. Attackers can craft malformed packets causing the process to consume huge amounts of memory resulting in a denial of service.

Specific Go Packages Affected

github.com/cloudflare/goflow/v3/decoders/sflow

Patches

Version 3.4.4 contains patches fixing this.

Workarounds

A possible workaround is to not have your goflow collector publicly reachable.

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/cloudflare/goflow/v3all versions3.4.4go get github.com/cloudflare/goflow/v3@v3.4.4

Affected Products

1 product · 1 configurations
Application
goflowcloudflare
< 3.4.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/cloudflare/goflow/v3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/cloudflare/goflow/v3 to 3.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2529 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

### Impact The sflow decode package prior to version 3.4.4 does not employ sufficient packet sanitisation which can lead to a denial of service attack. Attackers can craft malformed packets causing the process to consume huge amounts of memory resulting in a denial of service. ### Specific Go Packages Affected github.com/cloudflare/goflow/v3/decoders/sflow ### Patches Version 3.4.4 contains patches fixing this. ### Workarounds A possible workaround is to not have your goflow collector publicly reachable. ### For more information If you have any questions or comments about this advisory: *
O3 Security · Impact-Aware SCA

Is CVE-2022-2529 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-2529: goflow DoS — Fixed in 3.4.4