NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

CVE-2022-25167 — flume-jms-source

Fix: apache/flume@dafb26c

CVE-2022-25167 is a Improper Input Validation vulnerability in org.apache.flume.flume-ng-sources:flume-jms-source. A fix is available for org.apache.flume.flume-ng-sources:flume-jms-source — see the affected versions and patch details below.

Remote Code Execution in Apache Flume

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.2%probability of exploitation in next 30 days
Lower Risk+0.12%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
3.70%5.47%7.25%9.02%8.0%5.2%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
☕org.apache.flume.flume-ng-sources:flume-jms-source

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Apache Flume versions 1.4.0 through 1.9.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.flume.flume-ng-sources:flume-jms-source≥ 1.4.0&&< 1.10.01.10.0org.apache.flume.flume-ng-sources:flume-jms-source:1.10.0

Affected Products

1 product · 1 configurations
Application
flumeapache
≥ 1.4.0 && < 1.10.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.flume.flume-ng-sources:flume-jms-source, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.flume.flume-ng-sources:flume-jms-source to 1.10.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-25167 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Apache Flume versions 1.4.0 through 1.9.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.
O3 Security · Impact-Aware SCA

Is CVE-2022-25167 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-25167: flume-jms-source RCE — Fixed in 1.10.0