NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2022-2514 — fava

HIGHFix: beancount/fava@ca9e388

CVE-2022-2514 is a high-severity (CVSS 8) Cross-site Scripting (XSS) vulnerability in fava. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for fava — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Reflected in beancount/fava

Also known asGHSA-xrf4-39fm-j5f2PYSEC-2022-239
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.92%1.37%0.3%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍fava

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The time and filter parameters in Fava prior to v1.22 are vulnerable to reflected cross-site scripting due to the lack of escaping of error messages which contained the parameters in verbatim.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIfavaall versions1.22pip install --upgrade 'fava==1.22'

Affected Products

1 product · 1 configurations
Application
favafava_project
< 1.22
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for fava, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update fava to 1.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2514 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The time and filter parameters in Fava prior to v1.22 are vulnerable to reflected cross-site scripting due to the lack of escaping of error messages which contained the parameters in verbatim.
O3 Security · Impact-Aware SCA

Is CVE-2022-2514 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-2514: fava XSS — Fixed in 1.22