CVE-2022-24895 is a medium-severity (CVSS 6.3) CWE-384 vulnerability in symfony/security-bundle. A fix is available for symfony/security-bundle — see the affected versions and patch details below.
Symfony vulnerable to Session Fixation of CSRF tokens
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24895.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/security-bundle🐘symfony/security-bundle🐘symfony/security-bundle🐘symfony/security-bundle🐘symfony/security-bundle🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony+2 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Description
When authenticating users Symfony by default regenerates the session ID upon login, but preserves the rest of session attributes. Because this does not clear CSRF tokens upon login, this might enables same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation.
Resolution
Symfony removes all CSRF tokens from the session on successful login.
The patch for this issue is available here for branch 4.4.
Credits
We would like to thank Marco Squarcina for reporting the issue and Nicolas Grekas for fixing it.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/security-bundle | ≥ 2.0.0&&< 4.4.50 | 4.4.50composer require symfony/security-bundle:^4.4.50 |
| 🐘Packagist | symfony/security-bundle | ≥ 5.0.0&&< 5.4.20 | 5.4.20composer require symfony/security-bundle:^5.4.20 |
| 🐘Packagist | symfony/security-bundle | ≥ 6.0.0&&< 6.0.20 | 6.0.20composer require symfony/security-bundle:^6.0.20 |
| 🐘Packagist | symfony/security-bundle | ≥ 6.1.0&&< 6.1.12 | 6.1.12composer require symfony/security-bundle:^6.1.12 |
| 🐘Packagist | symfony/security-bundle | ≥ 6.2.0&&< 6.2.6 | 6.2.6composer require symfony/security-bundle:^6.2.6 |
| 🐘Packagist | symfony/symfony | ≥ 2.0.0&&< 4.4.50 | 4.4.50composer require symfony/symfony:^4.4.50 |
Affected Products
symfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/security-bundle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/security-bundle to 4.4.50 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24895 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2022-24895 in your dependencies?
Find it across Packagist, including transitive dependencies.