CVE-2018-11408 is a medium-severity (CVSS 6.1) Open Redirect vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Symfony Open Redirect
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/security-bundle🐘symfony/security-bundle🐘symfony/security-bundle+2 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The security handlers in the Security component in Symfony in 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11 have an Open redirect vulnerability when security.http_utils is inlined by a container. NOTE: this issue exists because of an incomplete fix for CVE-2017-16652.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.7.0&&< 2.7.48 | 2.7.48composer require symfony/symfony:^2.7.48 |
| 🐘Packagist | symfony/symfony | ≥ 2.8.0&&< 2.8.41 | 2.8.41composer require symfony/symfony:^2.8.41 |
| 🐘Packagist | symfony/symfony | ≥ 3.3.0&&< 3.3.17 | 3.3.17composer require symfony/symfony:^3.3.17 |
| 🐘Packagist | symfony/symfony | ≥ 3.4.0&&< 3.4.11 | 3.4.11composer require symfony/symfony:^3.4.11 |
| 🐘Packagist | symfony/symfony | ≥ 4.0.0&&< 4.0.11 | 4.0.11composer require symfony/symfony:^4.0.11 |
| 🐘Packagist | symfony/security-bundle | ≥ 2.7.0&&< 2.7.48 | 2.7.48composer require symfony/security-bundle:^2.7.48 |
Affected Products
debian linuxdebiansymfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.7.48 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-11408 is resolved across your whole dependency graph.
Workarounds
Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.
Frequently Asked Questions
Is CVE-2018-11408 in your dependencies?
Find it across Packagist, including transitive dependencies.