CVE-2022-24815 is a high-severity (CVSS 8.1) SQL Injection vulnerability in generator-jhipster. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for generator-jhipster — see the affected versions and patch details below.
SQL Injection when creating an application with Reactive SQL backend
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24815.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
generator-jhipsternpmDescription
Impact
SQL Injection vulnerability in entities for applications generated with the option "reactive with Spring WebFlux" enabled and an SQL database using r2dbc. Applications created without "reactive with Spring WebFlux" and applications with NoSQL databases are not affected.
If you have generated a microservice Gateway using the affected version, you might be impacted as Gateways are reactive by default.
Currently, SQL injection is possible in the findAllBy(Pageable pageable, Criteria criteria) method of an entity repository class generated in these applications as the where clause using Criteria for queries are not sanitized and user input is passed on as it is by the criteria.
Impacted applications
- Monolith and microservice applications with SQL database and reactive with Spring WebFlux combination (other combinations are not affected and the issue is only present when you generate entities)
- Gateway applications with SQL database (issue will appear only when generating entities)
Patches
Patched in v7.8.1
The findAllBy(Pageable pageable, Criteria criteria) method has been removed from the entity repositories and org.springframework.data.relational.core.query.Criteria support in the underlying methods has been replaced with org.springframework.data.relational.core.sql.Condition. This means you won't be able to do custom filtering in the generated applications.
If you have existing reactive applications generated by the impacted version, we advise you to audit for use of Criteria and take appropriate actions.
Workarounds
The problem lies in the EntityManager.java class when creating the where clause via Conditions.just(criteria.toString()).
just accepts the literal string provided. Criteria's toString method returns a plain string and this combination is vulnerable to sql injection as the string is not sanitized and will contain whatever used passed as input using any plain SQL
So be careful when combining criterias and conditions. As a workaround we have removed the possibility to pass any user-provided criteria to the createSelect method of EntityManager.
Example
Criteria criteria = Criteria.where("name").is("foobar';DROP TABLE example;--"); // parameter is user provided input
criteria.toString(); // --> "'foobar';DROP TABLE example;--'"
References
More details in this Issue report
For more information
If you have any questions or comments about this advisory:
- Open an issue in JHipster issue tracker
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | generator-jhipster | ≥ 7.0.0&&< 7.8.1 | 7.8.1npm install generator-jhipster@7.8.1 |
Affected Products
generator-jhipsterjhipsterResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for generator-jhipster, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update generator-jhipster to 7.8.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24815 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2022-24815 in your dependencies?
Find it across npm, including transitive dependencies.