NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-24802 — deepmerge-ts

HIGHFix: RebeccaStevens/deepmerge-ts@b39f1a9

CVE-2022-24802 is a high-severity (CVSS 8.1) CWE-915 vulnerability in deepmerge-ts. A fix is available for deepmerge-ts — see the affected versions and patch details below.

Prototype Pollution in deepmerge-ts

Also known asGHSA-r9w3-g83q-m6hq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24802.

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.18%0.84%1.51%2.18%0.7%1.7%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
deepmerge-tsnpm
30.2Mdownloads / week

Description

deepmerge-ts is a typescript library providing functionality to deep merging of javascript objects. deepmerge-ts is vulnerable to Prototype Pollution via file deepmerge.ts, function defaultMergeRecords(). This issue has been patched in version 4.0.2. There are no known workarounds for this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmdeepmerge-tsall versions4.0.2npm install deepmerge-ts@4.0.2

Affected Products

1 product · 1 configurations
Application
deepmerge-tsdeepmerge-ts_project
< 4.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for deepmerge-ts, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update deepmerge-ts to 4.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24802 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

deepmerge-ts is a typescript library providing functionality to deep merging of javascript objects. deepmerge-ts is vulnerable to Prototype Pollution via file deepmerge.ts, function defaultMergeRecords(). This issue has been patched in version 4.0.2. There are no known workarounds for this issue.
O3 Security · Impact-Aware SCA

Is CVE-2022-24802 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-24802: deepmerge-ts — Fixed in 4.0.2