CVE-2022-24798 is a high-severity (CVSS 7.5) CWE-212 vulnerability in irrd. A fix is available for irrd — see the affected versions and patch details below.
Insufficient password hash filtering in some IRRd queries and exports
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24798.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
irrdReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
IRRd did not always filter password hashes in query responses relating to mntner objects and database exports. This may have allowed adversaries to retrieve some of these hashes, perform a brute-force search for the clear-text passphrase, and use these to make unauthorised changes to affected IRR objects. This issue only affected instances that process password hashes, which means it is limited to IRRd instances that serve authoritative databases. IRRd instances operating solely as mirrors of other IRR databases are not affected.
The issue occurred:
- For
mntnerobjects where all password hash names (MD5-PWandCRYPT-PW) were in lower or mixed case in theauthattribute. For these objects, hashes remained in the output of all queries of any method and all database exports made with theexport_destinationsetting. Fortunately, objects in the common public IRR database virtually all use uppercase hash names which means very few of those objects were affected. - For any GraphQL queries that queried the
authfield onmntnerobjects. - For any GraphQL queries that queried the
objectTextfield on thejournalfield onmntnerobjects, if thenrtm_access_listsetting permitted journal access.
The two GraphQL cases are visible in logs, allowing users to determine whether any existing objects had their hashes exposed. This has been fixed in IRRd 4.2.3 and the main branch. Versions in the 4.1.x series never were affected. Users of the 4.2.x series are strongly recommended to upgrade. All users running a more recent version from the main branch should update to the latest version. Alternatively, but not recommended, apply the patch manually [for 4.2.x]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | irrd | ≥ 4.2.0&&< 4.2.3 | 4.2.3pip install --upgrade 'irrd==4.2.3' |
Affected Products
internet routing registry daemoninternet_routing_registry_daemon_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for irrd, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update irrd to 4.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24798 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-24798 in your dependencies?
Find it across PyPI, including transitive dependencies.