NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
CRITICAL severity

CVE-2022-24783 — deno

CRITICALFix: denoland/deno#14115

CVE-2022-24783 is a critical-severity (CVSS 10) Improper Privilege Management vulnerability in deno. A fix is available for deno — see the affected versions and patch details below.

Sandbox bypass leading to arbitrary code execution in Deno

Also known asGHSA-838h-jqp6-cf2f
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24783.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.55%1.10%1.65%0.4%1.1%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🦀deno

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass permission checks and execute arbitrary shell code.

There is no evidence that this vulnerability has been exploited in the wild.

This vulnerability does not affect users of Deno Deploy.

Patches

The vulnerability has been patched in Deno 1.20.3.

Workarounds

There is no workaround. All users are recommended to upgrade to 1.20.3 immediately


The cause of this error was that certain FFI operations did not correctly check for permissions. The issue was fixed in this pull request.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iodeno≥ 1.18.0&&< 1.20.31.20.3cargo update -p deno --precise 1.20.3

Affected Products

1 product · 1 configurations
Application
denodeno
≥ 1.18.0 && < 1.20.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for deno, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update deno to 1.20.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24783 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

### Impact The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass permission checks and execute arbitrary shell code. There is **no** evidence that this vulnerability has been exploited in the wild. This vulnerability does **not** affect users of Deno Deploy. ### Patches The vulnerability has been patched in Deno 1.20.3. ### Workarounds There is no workaround. All users are recommended to upgrade to 1.20.3 immediately --- The cause of this error was that certain
O3 Security · Impact-Aware SCA

Is CVE-2022-24783 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2022-24783: deno — Fixed in 1.20.3