CVE-2022-24775 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in guzzlehttp/psr7. A fix is available for guzzlehttp/psr7 — see the affected versions and patch details below.
Improper Input Validation in guzzlehttp/psr7
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-24775.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
guzzlehttp/psr7🐘guzzlehttp/psr7Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Improper header parsing. An attacker could sneak in a carriage return character (\r) and pass untrusted values in both the header names and values.
Patches
The issue is patched in 1.8.4 and 2.1.1.
Workarounds
There are no known workarounds.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | guzzlehttp/psr7 | all versions | 1.8.4composer require guzzlehttp/psr7:^1.8.4 |
| 🐘Packagist | guzzlehttp/psr7 | ≥ 2.0.0&&< 2.1.1 | 2.1.1composer require guzzlehttp/psr7:^2.1.1 |
Affected Products
drupaldrupalpsr-7guzzlephpDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for guzzlehttp/psr7, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update guzzlehttp/psr7 to 1.8.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24775 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-24775 in your dependencies?
Find it across Packagist, including transitive dependencies.