NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2022-24437 — git-pull-or-clone

CRITICALFix: feross/git-pull-or-clone@f9ce092

CVE-2022-24437 is a critical-severity (CVSS 9.8) CWE-88 vulnerability in git-pull-or-clone. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for git-pull-or-clone — see the affected versions and patch details below.

Command Injection

Also known asGHSA-3x62-x456-q2vmSNYK-JS-GITPULLORCLONE-2434307
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
1.74%5.29%8.84%12.4%10.4%3.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

42other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
git-pull-or-clonenpm
66downloads / week

Description

The package git-pull-or-clone before 2.0.2 is vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection.

Credits

Credit @lirantal for discovering this vulnerability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmgit-pull-or-cloneall versions2.0.2npm install git-pull-or-clone@2.0.2

Affected Products

1 product · 1 configurations
Application
git-pull-or-clonegit-pull-or-clone_project
< 2.0.2
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for git-pull-or-clone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update git-pull-or-clone to 2.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-24437 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The package git-pull-or-clone before 2.0.2 is vulnerable to Command Injection due to the use of the --upload-pack feature of git which is also supported for git clone. The source includes the use of the secure child process API spawn(). However, the outpath parameter passed to it may be a command-line argument to the git clone command and result in arbitrary command injection. ## Credits Credit @lirantal for discovering this vulnerability.
O3 Security · Impact-Aware SCA

Is CVE-2022-24437 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-24437: git-pull-or — Fixed in 2.0.2