NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2022-23793 — archive

HIGH

CVE-2022-23793 is a high-severity (CVSS 7.5) Path Traversal vulnerability in joomla/archive. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for joomla/archive — see the affected versions and patch details below.

Path Traversal within joomla/archive tar class

Also known asBIT-joomla-2022-23793GHSA-jm67-jh3g-cg3f
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.00%0.90%1.79%2.69%0.0%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘joomla/archive🐘joomla/archive

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Joomla! 3.0.0 through 3.10.6 & 4.0.0 through 4.1.0. Extracting an specifilcy crafted tar package could write files outside of the intended path.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistjoomla/archiveall versions1.1.12composer require joomla/archive:^1.1.12
🐘Packagistjoomla/archive≥ 2.0.0&&< 2.0.12.0.1composer require joomla/archive:^2.0.1

Affected Products

1 product · 2 configurations
Application
joomla\!joomla
≥ 4.0.0 && ≤ 4.1.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for joomla/archive, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update joomla/archive to 1.1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23793 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

An issue was discovered in Joomla! 3.0.0 through 3.10.6 & 4.0.0 through 4.1.0. Extracting an specifilcy crafted tar package could write files outside of the intended path.
O3 Security · Impact-Aware SCA

Is CVE-2022-23793 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-23793: archive — Fixed in 1.1.12