CVE-2022-23494 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in tinymce. A fix is available for tinymce — see the affected versions and patch details below.
Cross-site scripting vulnerability in TinyMCE alerts
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
tinymcenpmDescription
Impact
A cross-site scripting (XSS) vulnerability was discovered in the alert and confirm dialogs when these dialogs were provided with malicious HTML content. This can occur in plugins that use the alert or confirm dialogs, such as in the image plugin, which presents these dialogs when certain errors occur. The vulnerability allowed arbitrary JavaScript execution when an alert presented in the TinyMCE UI for the current user.
Patches
This vulnerability has been patched in TinyMCE 5.10.7 and TinyMCE 6.3.1 by ensuring HTML sanitization was still performed after unwrapping invalid elements.
Fix
To avoid this vulnerability:
- Upgrade to TinyMCE 5.10.7 or higher for TinyMCE 5.x.
- Upgrade to TinyMCE 6.3.1 or higher for TinyMCE 6.x.
Workaround
To reduce the impact of this vulnerability:
- Ensure the the
images_upload_handlerreturns a valid value as per the images_upload_handler documentation.
References
- https://www.tiny.cloud/docs/release-notes/release-notes5107/#securityfixes
- https://www.tiny.cloud/docs/tinymce/6/6.3-release-notes/#security-fixes
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
- Open an issue in the TinyMCE repo
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | tinymce | ≥ 6.0.0&&< 6.3.1 | 6.3.1npm install tinymce@6.3.1 |
| 📦npm | tinymce | all versions | 5.10.7npm install tinymce@5.10.7 |
| .NETNuGet | TinyMCE | ≥ 6.0.0&&< 6.3.1 | 6.3.1dotnet add package TinyMCE --version 6.3.1 |
| .NETNuGet | TinyMCE | all versions | 5.10.7dotnet add package TinyMCE --version 5.10.7 |
| 🐘Packagist | tinymce/tinymce | ≥ 6.0.0&&< 6.3.1 | 6.3.1composer require tinymce/tinymce:^6.3.1 |
| 🐘Packagist | tinymce/tinymce | all versions | 5.10.7composer require tinymce/tinymce:^5.10.7 |
Affected Products
tinymcetinyDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tinymce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tinymce to 6.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23494 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2022-23494 in your dependencies?
Find it across npm, NuGet, Packagist, including transitive dependencies.