CVE-2022-23107 — warnings-ng
HIGHCVE-2022-23107 is a high-severity (CVSS 8.1) Path Traversal vulnerability in io.jenkins.plugins:warnings-ng. A fix is available for io.jenkins.plugins:warnings-ng — see the affected versions and patch details below.
Path Traversal in Jenkins Warnings Next Generation Plugin
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.jenkins.plugins:warnings-ng☕io.jenkins.plugins:warnings-ng☕io.jenkins.plugins:warnings-ng☕io.jenkins.plugins:warnings-ngReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins Warnings Next Generation Plugin prior to 9.10.3, 9.7.1, 9.5.2, and 9.0.2 does not restrict the name of a file when configuring a custom ID.
This allows attackers with Item/Configure permission to write and read specific files with a hard-coded suffix on the Jenkins controller file system.
Jenkins Warnings Next Generation Plugin 9.10.3, 9.7.1, 9.5.2, and 9.0.2 checks for the presence of prohibited directory separator characters in the custom ID.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.jenkins.plugins:warnings-ng | ≥ 9.8.0&&< 9.10.3 | 9.10.3io.jenkins.plugins:warnings-ng:9.10.3 |
| ☕Maven | io.jenkins.plugins:warnings-ng | ≥ 9.6.0&&< 9.7.1 | 9.7.1io.jenkins.plugins:warnings-ng:9.7.1 |
| ☕Maven | io.jenkins.plugins:warnings-ng | ≥ 9.1.0&&< 9.5.2 | 9.5.2io.jenkins.plugins:warnings-ng:9.5.2 |
| ☕Maven | io.jenkins.plugins:warnings-ng | all versions | 9.0.2io.jenkins.plugins:warnings-ng:9.0.2 |
Affected Products
warnings next generationjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.jenkins.plugins:warnings-ng, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.jenkins.plugins:warnings-ng to 9.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-23107 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2022-23107 in your dependencies?
Find it across Maven, including transitive dependencies.