NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2022-22980 — spring-data-mongodb

CRITICAL

CVE-2022-22980 is a critical-severity (CVSS 9) Expression Language Injection vulnerability in org.springframework.data:spring-data-mongodb. 13 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.springframework.data:spring-data-mongodb — see the affected versions and patch details below.

SpEL Injection in Spring Data MongoDB

Also known asGHSA-w24x-87mr-4r23
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
13 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
17.8%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%83.2%17.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.springframework.data:spring-data-mongodb☕org.springframework.data:spring-data-mongodb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A Spring Data MongoDB application is vulnerable to SpEL Injection when using @Query or @Aggregation-annotated query methods with SpEL expressions that contain query parameter placeholders for value binding if the input is not sanitized.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.data:spring-data-mongodb≥ 3.4.0&&< 3.4.13.4.1org.springframework.data:spring-data-mongodb:3.4.1
☕Mavenorg.springframework.data:spring-data-mongodball versions3.3.5org.springframework.data:spring-data-mongodb:3.3.5

Affected Products

1 product · 2 configurations
Application
spring data mongodbvmware
≤ 3.3.4
1 version
3.4.0
Exploits & PoCs
13

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.data:spring-data-mongodb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.data:spring-data-mongodb to 3.4.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-22980 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

A Spring Data MongoDB application is vulnerable to SpEL Injection when using @Query or @Aggregation-annotated query methods with SpEL expressions that contain query parameter placeholders for value binding if the input is not sanitized.
O3 Security · Impact-Aware SCA

Is CVE-2022-22980 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-22980: spring-data-mongodb — Fixed in 3.4.1