NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2022-22978 — spring-security-core

CRITICAL

CVE-2022-22978 is a critical-severity (CVSS 9.8) CWE-863 vulnerability in org.springframework.security:spring-security-core. 6 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.springframework.security:spring-security-core — see the affected versions and patch details below.

Authorization bypass in Spring Security

Also known asGHSA-hh32-7344-cg2f
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
6 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
12.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%90.7%12.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-core☕org.springframework.security:spring-security-web☕org.springframework.security:spring-security-web☕org.springframework.security:spring-security-web

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet containers. Applications using RegexRequestMatcher with . in the regular expression are possibly vulnerable to an authorization bypass.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.springframework.security:spring-security-core≥ 5.5.0&&< 5.5.75.5.7org.springframework.security:spring-security-core:5.5.7
☕Mavenorg.springframework.security:spring-security-core≥ 5.6.0&&< 5.6.45.6.4org.springframework.security:spring-security-core:5.6.4
☕Mavenorg.springframework.security:spring-security-coreall versions5.4.11org.springframework.security:spring-security-core:5.4.11
☕Mavenorg.springframework.security:spring-security-web≥ 5.5.0&&< 5.5.75.5.7org.springframework.security:spring-security-web:5.5.7
☕Mavenorg.springframework.security:spring-security-web≥ 5.6.0&&< 5.6.45.6.4org.springframework.security:spring-security-web:5.6.4
☕Mavenorg.springframework.security:spring-security-weball versions5.4.11org.springframework.security:spring-security-web:5.4.11

Affected Products

3 products · 7 configurations
Application
active iq unified managernetapp
all
Application
financial services crime and compliance management studiooracle
2 versions
8.0.8.2.08.0.8.3.0
Application
spring securityvmware
≥ 5.6.0 && < 5.6.4
range
Exploits & PoCs
6

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.springframework.security:spring-security-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.springframework.security:spring-security-core to 5.5.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-22978 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OCP-Tools-4.13-RHEL-8jenkins-0:2.387.3.1684911776-3.el8RHSA-2023:3299
Red Hat Fuse 7.11spring-securityRHSA-2022:5532

Frequently Asked Questions

In spring security versions prior to 5.4.11+, 5.5.7+ , 5.6.4+ and older unsupported versions, RegexRequestMatcher can easily be misconfigured to be bypassed on some servlet containers. Applications using RegexRequestMatcher with `.` in the regular expression are possibly vulnerable to an authorization bypass.
O3 Security · Impact-Aware SCA

Is CVE-2022-22978 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2022-22978: spring-security-core — Fixed in 5.5.7