CVE-2022-22577 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in actionpack. A fix is available for actionpack — see the affected versions and patch details below.
Cross-site Scripting Vulnerability in Action Pack
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
actionpack💎actionpack💎actionpack💎actionpackReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
There is a possible XSS vulnerability in Rails / Action Pack. This vulnerability has been assigned the CVE identifier CVE-2022-22577.
Versions Affected: >= 5.2.0 Not affected: < 5.2.0 Fixed Versions: 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1
Impact
CSP headers were only sent along with responses that Rails considered as "HTML" responses. This left API requests without CSP headers, which could possibly expose users to XSS attacks.
Releases
The FIXED releases are available at the normal locations.
Workarounds
Set a CSP for your API responses manually.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | actionpack | ≥ 5.2.0&&< 5.2.7.1 | 5.2.7.1bundle update actionpack --conservative |
| 💎RubyGems | actionpack | ≥ 6.0.0&&< 6.0.4.8 | 6.0.4.8bundle update actionpack --conservative |
| 💎RubyGems | actionpack | ≥ 6.1.0&&< 6.1.5.1 | 6.1.5.1bundle update actionpack --conservative |
| 💎RubyGems | actionpack | ≥ 7.0.0&&< 7.0.2.4 | 7.0.2.4bundle update actionpack --conservative |
Affected Products
debian linuxdebianactionpackrubyonrailsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for actionpack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update actionpack to 5.2.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-22577 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.13 for RHEL 8 | tfm-rubygem-actionpack-0:6.1.7-1.el8sat | RHSA-2023:2097 |
Frequently Asked Questions
Is CVE-2022-22577 in your dependencies?
Find it across RubyGems, including transitive dependencies.